Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
martin-144

FLX and Artnet [Raspi]

Recommended Posts

Hi,

Today it seems a lot of Artnet Questions arise. Here is mine:

I tried to control a Raspberry PI configured as a Media Server running OLA through Artnet without luck.
The FLX is attached to an Access Point which delivers IP adresses in the Range 192.168.0.* to its wifi clients through DHCP (which includes the PI).
The FLX is cabled to the AP and has a fixed address in the 192.168.0.* range.
In the Manual I read that Artnet can only be delivered to IP addresses ranging in the 10.* or 2.* address range.

Does that mean I have to configure the PI to additionally listen on and having configured an IP address on the 10.* range to receive Artnet?
May this be correctly routed through the Access Point if not configured explicitly?

Regards,
Martin

Share this post


Link to post
Share on other sites

Hi Martin,

Yes that's correct.

For the Pi to receive Art-Net from FLX, it must be in the same range. Therefore choose either the 2.x.x.x or 10.x.x.x address on FLX, and assign the Pi an address in the same range. An example if FLX is on the 10.x.x.x range, could be an IP on the Pi of 10.1.1.1 with a subnet of 255.0.0.0. 

The Pi will have two NICs (Network Interface Cards), one for the RJ45 port and the other for WiFi. Therefore the RJ45 port can be configured on the 10.x.x.x range and the wireless can be set to DHCP.

You should find that if your access point has an Ethernet switch built in to allow the FLX and Pi to be connected, that the Art-Net information will be routed correctly.

Hope this helps, let me know if you have any queries.

Edward

Share this post


Link to post
Share on other sites

Hi,

slowly going to understand things:

I added a new file in /etc/network/interfaces.d/wlan0-artnet with the following content:

Quote

auto wlan0:1
iface wlan0:1 inet static
    address 10.0.0.2
    netmask 255.0.0.0
    gateway 10.0.0.1

This creates a new wlan0 interface on wlan0 with the required IP address. Adjust to your own IP adress.
Works for me at home. Lets see for my theatre setup tomorrow.

Martin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.