Jump to content
Zero 88 Community Support Forum
Uriahdemon

Basic Networking Guide - FLX & ZerOS Remote

Recommended Posts

Hi,  I am having quite a bit of trouble trying to get my iPAD running ZerOS Remote to connect to my FLX desk.  That is not entirely surprising as I am not too sharp when it comes to networking setups.  I was wondering if anyone has or can point in the way of some basic advice on how to do this.  I have 'Remote' enabled etc but still no joy at all.  I am guessing it is to do with IP addressing but not too sure where to start with it all.

Share this post


Link to post
Share on other sites
16 hours ago, kgallen said:

Thanks Kevin, much appreciated.

On reading this I am pretty sure I have covered off all the recommendations but I still cannot get the FLX to connect to the router.  I have the FLX set up to run CAPTURE,  would anything done there affect connection to the router.  Also if and when I manage to set up the router would any of that set up config affect what I have in place for CAPTURE.  Slightly off topic I know none the less important.

 

PS...  I have tried 3 different cables

Share this post


Link to post
Share on other sites

Sorry, I don't know. However I will be interested in the answer from Edward as I might end up investing in CAPTURE soon too...

Sorry I can't help any more!

Share this post


Link to post
Share on other sites
2 hours ago, kgallen said:

Sorry, I don't know. However I will be interested in the answer from Edward as I might end up investing in CAPTURE soon too...

Sorry I can't help any more!

thanks anyway.

Share this post


Link to post
Share on other sites

Hi Mac,

Hope you're well.

So I'm guessing your network setup is FLX plugged into one Ethernet port of your wireless router, and your PC plugged into another running Capture?

On FLX is Capture set to use a static IP address? Is the Remote on FLX set to DHCP? If so you can confirm the status of these settings outside of Setup, by tapping Z -> System Information -> Network Overview. At the top you should see a line of text displaying "DHCP address", and then list the IP you have been assigned. Can you confirm this is in the same range as your iPad, and that it is reporting no errors?

You can find out your iPad's IP address in iOS by tapping the Settings app -> WiFi -> Tap your router's network. Your IP and subnet will be listed. In a simple network like this, as long as the first 3 values of the IP address are the same, and the last value is different on all devices connected, you should be fine.

After changing configurations such as changing IP addresses or swapping out Ethernet cabling, make sure you disable and re-enable the remote connection, otherwise you may experience a socket error.

If you have any queries as always just let me know,

Edward

Share this post


Link to post
Share on other sites
2 hours ago, Edward- Z88 said:

Hi Mac,

Hope you're well.

So I'm guessing your network setup is FLX plugged into one Ethernet port of your wireless router, and your PC plugged into another running Capture?

On FLX is Capture set to use a static IP address? Is the Remote on FLX set to DHCP? If so you can confirm the status of these settings outside of Setup, by tapping Z -> System Information -> Network Overview. At the top you should see a line of text displaying "DHCP address", and then list the IP you have been assigned. Can you confirm this is in the same range as your iPad, and that it is reporting no errors?

You can find out your iPad's IP address in iOS by tapping the Settings app -> WiFi -> Tap your router's network. Your IP and subnet will be listed. In a simple network like this, as long as the first 3 values of the IP address are the same, and the last value is different on all devices connected, you should be fine.

After changing configurations such as changing IP addresses or swapping out Ethernet cabling, make sure you disable and re-enable the remote connection, otherwise you may experience a socket error.

If you have any queries as always just let me know,

Edward

Hi Ed, I am well, hopefully the same with you.

OK,  I am giving this another go this evening and to start with I made a fatal (numpty) mistake.  I had actually plugged the ethernet cable into the internet port in the router.  I plugged it into one of the ethernet ports and I now have ZerOS Remote talking to the desk.

I did not try Capture at the same time last night but have now configured it as you state above i.e. 'FLX plugged into one Ethernet port of your wireless router, and your PC plugged into another running Capture'.  The trouble I have now is that the desk is not talking to Capture.  I used a direct connection from the desk to my laptop previously and all worked fine but unfortunately not now.

The Network Overview info is as following:

DHCP - IP Address - 192.168.0.102

Capture - Transmitting on - 192.168.0.102

Remote - Listening on - 192.168.0.102 - 1 connection active

IPAD address when looking at the Router wifi link info - 192.168.0.101

Capture is Enabled and 'Use DHCP Address' is enabled. 

On FLX - Remote is Enabled as is DHCP

 

Hopefully the end game with this set up is to be able to:

When programming use Capture for visualisation so just the FLX console into the router and router connected to laptop.

When in live scenario use ZerOS Remote connected to router and laptop running Phantom OS with unlock dongle as a back up just in case.

Thanks again for your help, much appreciated.

Mac

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Mac,

13 hours ago, Uriahdemon said:

The Network Overview info is as following:

DHCP - IP Address - 192.168.0.102

Capture - Transmitting on - 192.168.0.102

Remote - Listening on - 192.168.0.102 - 1 connection active

Capture is Enabled and 'Use DHCP Address' is enabled. 

On FLX - Remote is Enabled as is DHCP

As you have both Capture and Remote using DHCP it means these different protocols are on the same IP address. I would recommend setting Capture to 192.168.0.10 rather than DHCP. You should find your laptop will now listen to FLX.

13 hours ago, Uriahdemon said:

When programming use Capture for visualisation so just the FLX console into the router and router connected to laptop.

You will still be able to connect directly into your laptop if you don't wish to use the Remote. You may find you'll need to disable/re-enable Capture after unplugging network cabling.

Any queries let me know.

Edward

Share this post


Link to post
Share on other sites
9 hours ago, Edward- Z88 said:

Hi Mac,

As you have both Capture and Remote using DHCP it means these different protocols are on the same IP address. I would recommend setting Capture to 192.168.0.10 rather than DHCP. You should find your laptop will now listen to FLX.

You will still be able to connect directly into your laptop if you don't wish to use the Remote. You may find you'll need to disable/re-enable Capture after unplugging network cabling.

Any queries let me know.

Edward

Hi Ed, now working a treat, thanks very much for your help.  Now for me to get an unlock dongle and set up the laptop as a tracking back up.  Best Rgds

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.