Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
timeofsilence

Frog2 Power Supply Squeal

Recommended Posts

I took the leap from a Fat Frog to a Frog 2. It arrived yesterday. While setting it up I came across a few issues, one is that the power supply is making a high pitched squealing sound. It gets pretty warm too. I'm not sure if this is normal or not. Also, I have a mouse plugged in to the PS2 mouse port and it doesn't seem to be working. I plugged a trackball in to one of the USB ports and it only worked intermittently. Any thoughts on this would be greatly appreciated. For what its worth, the desk is still on OS4 I believe. I tried updated with a thumb drive last night to no avail. I will try the CD version today.

Share this post


Link to post
Share on other sites

Is it actually a Frog 2 PSU? The Frog 2 variant has a switch on the PSU case and (from memory) gives a higher current. Your Frog 2 would probably start up with a Frog PSU but it might well run warm and the USB hub might not have enough current to drive peripherals.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.