Jump to content
Zero 88 Community Support Forum

Phantom Exit issues

Recommended Posts

Hi guys.
It's been more than a while since I've used Zero88 consoles, since I switched to a different company which held Avolites only, but now got an opourtunity to buy Leap frog 48 for rather low price, so I did, because I loved that desk the time I worked with it, although there were quite a few software issues I'd love to have solved... I'm getting it within a few days.

Anyway, since my last usage, you made an update to 7.8. Haven't been able to check all of the changes just yet, but I already have an issue that I really can't deal with: Phantom ZerOS on Windows still has issues when exiting the application. I clearly remember this issue on Windows 7. I'm using 8.0 now, and it's still the same. Every time I try to quit the app with either Alt+F4, Close button, or even End task via task manager, the output monitor window reappears in another instance, so after trying a while I got like 20 instances of Output monitor window.


What's the secret in exiting this app?

Also, 2 different issues: First run - freeze with output monitor saying something like "Nothing to load" or something....
Nest start, I got "Non-Volatile RAM retention test failed. The internal battery may need replacing - Please contact a service agent".

Why would I get these errors in Phantom ZerOS?

I really hope the software works out better on the console itself.... :/


Hope to get your reply! :)

Share this post

Link to post
Share on other sites

The 2 issues you mention are very likely the result of the Phantom kernel having to use a register on the host PC to provide a 'consistent' value for the battery and NovRam test (I'm guessing). It could be that they're BIOS values which are published (and can usually be expected to be consistent) but on some PC's they might vary.


My understanding is that the software you see for Phantom ZerOS is the same source code as on the desk but running in an emulation environment of some kind - it could be that the emulator rather than using a discrete/value for those two power on tests uses a register on the host PC. When ZerOS gets those values on your PC, they're out of range or simply 'invalid' values - it doesn't "know" it's running in a emulator and so produces the error messages you've discovered.


FWIW - I just tried my copy of Phantom ZerOS (on Windows 7 Enterprise 64 bit) and it's fine and it works well enough for me to pootle around and check keystrokes when I need to support someone over the phone. We've also got the latest release ZerOS on our hire unit and it works perfectly well, so I guess that the issue is really just the way that Phantom ZerOS is run on a PC.


I shouldn't worry too much and enjoy your desk when it arrives with you! :)

Share this post

Link to post
Share on other sites

Ok. Got it (partially) for the Phantom, thanks for your reply. As for your kast sentence, doesn't seem like I will. Got a crash on my first day playing around with it. :/


I'll contact you directly for support, in case this will be possible...

Share this post

Link to post
Share on other sites

Hi Cucolino,


What version of software are you running? Did you get a debug file from the crash?


Please contact me directly to report crashes, so we can investigate them asap for you.


Best regards



Share this post

Link to post
Share on other sites

If you close the small ZerOS window (with the drop down, tick boxes and "Settings" / "About" / "Go" buttons on it), the application will start shutting down, which takes around 5 - 10 seconds. If you wait that long, it should close successfully.

Share this post

Link to post
Share on other sites

Nope. It does close within few seconds, but Windows still reports AppCrach afterwards.

"The application has closed unexpectedly".


Error module: ntdll.dll


Win7 x64 Home Premium, quite fresh install (couple months...)
Same issue for long time now...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.