Jump to content
Zero 88 Community Support Forum
Sign in to follow this  

No DMX on Leapfrog

Recommended Posts


I've been trying to fix this Leapfrog with no luck. V10.12.1 OS

It boots up no problem, the leds on the dmx out are lit, everything appears to work, but no control out of the dmx.

I even tried swapping the dmx board from a fat frog, it works on the fatfrog, but it's dmx doesn't on the leapfrog,I swapped them back after, as I know they aren't exactly the same.

I tried cleaning the contacts on the memory card.



Share this post

Link to post
Share on other sites

The DMX Cards are the same card, except on the Fat Frog there are a couple of links to make it output the same DMX universe on the two connectors (on the LeapFrog there are two universes of course). If there isn't any DMX coming out then the problem is on the mainboard itself, the good news is that the board is possibly repairable/replaceable being a LeapFrog.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.