Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
Paul SWAV

Fat Frog lights up breifly & won't start intermittant

Recommended Posts

Hi

I'm a repair tech at a company that sets up concerts, events etc.

I see some posts kind of similar, but not quite.

Our Fat Frog lights up briefly & won't start, no lcd display, intermittently.

I plug it in, all the leds and lights flash on briefly, then go off.

Most of the time it will work. One time it got stuck loading at 44% and froze.

V.10.12.1

I tried tightening all the connectors, and cleaning the contacts on the memory cards,

Since it is so random, I don't know if it helped yet, but any feedback would be appreciated

Thank you

Paul

Share this post


Link to post
Share on other sites

If you know the battery on the mainboard is ok then it might be bad news, the mainboard itself might have failed.

 

However it would be worth swapping the battery to see if that makes a difference (but usually the desk will power up and simply not retain memories) so I suspect it may be more than that. If you have one about, try swapping PSU's (or if you have a Jester PSU then it should power a Fat Frog).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.