Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
macaw

Betapack 3 Channels 1 & 2

Recommended Posts

Our church purchased three Betapack 3 units about 18 months ago. Until recently they've worked absolutely fine however last week we noticed a problems with channels 1 and 2 on one of the units.

 

When fading up the channels the lamps would suddenly jump to full brightness rather than fading up smoothly. When set to anything less than 100% the lamps would flicker, plus there seemed to be some sort of interference between the two channels - when one channel was faded up it caused the other to flicker for example. I'm fairly certain the fault is with the dimmer rather than the board, infact on one occasion when I had shut the board down before going to turn off the dimmer packs the lamps on one of the faulty channels suddenly randomed flashed on and off!

 

I would be very grateful for any advice.

 

Phil

Share this post


Link to post
Share on other sites

Hi Phil,

 

That sounds like a fault with a component in the dimmer sync circuit for that pair of channels.

Can you PM on the address below with the unit serial number so we can take this further.

Share this post


Link to post
Share on other sites

Hi Keith

 

Many thanks for your quick response. I'll get the serial number on Sunday and message you next week.

 

Thanks again

 

Phil.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.