Jump to content
Zero 88 Community Support Forum
Sign in to follow this  

Mambo Frog & Robe Fog 1500FT Problem.

Recommended Posts

We have a Mambo Frog running 6 Mac 250+'s, and 8 Shiva 200's. Also on the dmx line is a Robe 1500FT that many times more than not, when we hit the fog button on the frog, the Robe fogger does not respond, you have to press the button a few more times or leave your finger on the button until the fogger responds.


We have tried two different DMX adresses, two different buttons, and after a SCR failure, we even ended up with a new Mainboard in the Robe too. None of this has solved the problem, the Robe controller is always showing DMX control, so it IS waiting for the command from the Frog. It just seems that sometimes it doesn't realise that the Frog is saying "More Fog!" When used stand alone, the fogger fogs every time you hit the botton on the remote. On the first mainboard, sometimes the fogger wouldn't even realise you had DMX connected, and it would show "Ready" on the remote, you would have to use the Robe remote to get fog for the entire night! Resetting the desk, and/or the fogger would not fix the problem. The following night it would all work fine!


We have done the "Resistor on the DMX board" mod on the Frog and I'm wondering if theres another issue with the DMX thats causing the Robe to not read the signal properly.


This is a difficult issue as we are not sure if the issue is with the Frog, or with the Robe, all the other FX and dimmers work fine, and work the moment they are called, the Robe just seems to be a little hard of hearing!

I would have expected that if the issue was with the Robe, a new mainboard would have solved it.


Has anyone else with this same combo of a Mambo Frog (Or any frog for that matter, as I think they all have similar DMX boards) and a Robe 1500FT had this issue.

Share this post

Link to post
Share on other sites

Hi Halo


Do you have an opportunity to move the fog machine next to the desk (or vica versa) to check that this is not a cabling fault?


Also, have you tried an alternative desk with the fog machine? I've heard of some fog machines that don't like the DMX signal which the Frogs give out, even though the signal is within spec - some manufacturers interpret the specification differently.


Do all your other fixtures respond correctly?

Share this post

Link to post
Share on other sites

Have tried a direct feed, and all other fixtures, 6 Macs, 8 Shivas, and Atomic Strobe, a 12 chanell dimmer rack and a few switch packs all respond the moment their buttons are pressed. The fogger almost acts like the old ones that would either heat, or fog, but not both at once, you had to keep pressing the button until the darn thing worked. I have tried just using the fogger remote, with no DMX, and the fogger operates EVERY time its told to!


Even though all the lights are working, i did add a terminator today just for a gas, but the fogger still seems unhappy.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.