Jump to content
Zero 88 Community Support Forum

Function Buttons Not Working

Recommended Posts

  • Press F2
    Select the required attribute by pressing COLOUR, BEAMSHAPE or POSITION as required.
    Select the required palette to name using the palette selection buttons.
    Enter text via external keyboard.
    Press ENTER to complete operation.

If that still doesn't work - let us know and we will investigate.

Link to post
Share on other sites

Hi Gary! Hello K-Nine!


I noticed the same thing at a work last weekend. After programming a while the naming function suddenly failed. Switching off an on again fixed the problem. What happend directly before the function hung up I can not retrace but I will investigate that problem further on.

Link to post
Share on other sites

Can anyone give us any clues how to reproduce this? I just can't get it to fail :(


Is this problem new to 10.4, or has anyone seen it in any previous versions?


Do the other function keys still work when F2 fails?


Does F2 fail both with the button on the desk and on the external keyboard?




... and I know this might sound odd, but if anyone does see it fail, can you try pressing and releasing CTRL on the external keyboard, and then try F2 again. Looking at the source code, one thing that might inhibit the F2 naming function from working, is if the desk thinks CTRL is held down, in which case the function keys (on the external keyboard at least) change to mimicking the remote switches. Just an idea...

Link to post
Share on other sites

Hello Paul!


In OS 9.6 und 9.8 I already had some times that my LeapFrog hung up when naming the memories, subs or palettes. And not only the external keyboard did not work but also the function of the faders and wheels failed.

Tomorrow I have to programm a show for the weekend, so I make a test what exactly will happen at OS 10.4 when using the naming function.

Link to post
Share on other sites

Hello to all!


Now I can tell you more about the F2-failure.

I did the programming of single subs, mems and palettes and naming them without problems for a while. Then I pressed the F1 button for locking the palettes-screen because I wanted to programm one position-palette after another. As I wanted to give the first palette a name the desk accepted all commands but not the typing of the letters on the external keyboard. The selection of letters with the + and - keys worked. That way not only at the palettes but (after release the F1 lock-function) also at the memories and submasters. Also the direct input of a memory number to jump to was out of order.

The only way to get the desk back to right work was a power-on-reset.

Bizzarrely... if I wanted to force the error to come up again, it didn't. I could not reproduce the error. So maybe there has to be another fact before pressing F1 + F2, but I couldn't find it.


What an oddity! :?

Yesterday evening the full rehearsal for the today's event took place. During that the desk was in use for many hours without any problem (and without programming). After the end of the rehearsal I wanted to programm some additional palettes --> You can guess: The naming function failed when programming the first palette -- but without pressing the F1-button and without any clue why it happened! :(

The power-on-reset helped again and I could program and give names on the desk without further problems.

I have no idea what command before using the F2 is the cause for the failure.

Link to post
Share on other sites

Hello to all!


Yesterday I tried again the F2-error to come up. I programmed dozens of memeories, submasters and palettes in many different ways, but curiously nothing bad happend. In between I switched into "Super User" and changed some desk setups but the naming function didn't fail.

Except one time as I used the F1-button to freeze the palette-screen (as I described earlier). After switching the power off and on again I repeated all steps as before but --> nothing. The failure did not appear again. It is very strange to me.

Is it possible that it has something to do with an overflow of an interal buffer or something like this, cleared and ready again by the power-on-reset?


Is anyone out there in the frog-world who has made similar experiences :?: :?: :?:

Link to post
Share on other sites
  • 7 months later...

Hello all,


Last weekend I locked the attributes/palettes (Color, Beamshape, Pos) on my Leap Frog (using 10.4) for over a couple of hours and used the desk in that mode.


After that I wanted to unlock them for coming back to normal mode.

I pressed the F1-Key on the desk and nothing happened :cry:


If I lock the attributes shortly (saying for a couple of minutes) everything works fine. I tried to reproduce the problem but it was not possible (for now) to do so.


Has anyone got the same problem with the desk?




Link to post
Share on other sites
  • 2 years later...

Hey Guys,


F1, F2, F3, F4 not reponding.


I run a Fat Frog with version 10.9 all was fine in rehearsal on Thursday I could you the F1 to lock the pallet screen and F2 to name my sub-masters. Then on Sunday evening I went to name some new programs and the F2 wasn't responding, and F1 was using locking the palettes but not unlocking them.


Any help would be appreciated.

Link to post
Share on other sites

This seems to be a problem that occurs randomly, but so far hasn't been able to be reproduced for investigation. If anyone can find a way to make a desk do this repeatably then please let us know so we can look into it!


If you do get a desk into a state where it's doing this, please try as many other buttons as possible to see what does and doesn't work, as this may give us some clues as to what is going on. Also please save your showfile and post it here, as this may help to reproduce the problem.


Unfortunately for now the only fix seems to be to switch the desk off and on again to bring the function buttons back to life.


Does this problem only occur if an external keyboard is plugged in, or without as well?


Does this problem still occur in version 10.10? There was a change in version 10.10 (Frog Reference 5546) to flush unprocessed button repeat events as soon as that button is released - this may potentially affect this problem.

Link to post
Share on other sites
  • 10 months later...

i am using a fat frog in a show today and have programmed about 15 scenes no problem and names them all but for some reason it now wont let me name any other memories that i program pressing F2 doesn't do anything on the desk or keyboard its like its ignoring me, can anyone help? could do with a response by 3.00pm today

Link to post
Share on other sites
  • 5 years later...

I know this is an old thread - but I've recently acquired a fat frog and been happily using it for a few days naming memories with F2, but half way through programming it stopped letting me rename - almost as if the button had broken. Reading through this thread it looks as if it was a common issue.


Powering off and on again didn't solve it either.


Did this 'bug' ever get fixed?

Link to post
Share on other sites

As the reboot didn't help, probably need to rule out a hardware problem.


With the desk unpowered hold down F1, then power the desk keeping F1 held until the main LCD shows a test page. Press the channel flash button for channel 14 to get the button test page. Pressing buttons should now give an indication on the LCD (if I remember right!). See if pressing F2 is observed...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.