Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
yellaasian

Qulaity control

Recommended Posts

Hay The Club I Work for just bought a Leap Frog recently And 4 of the bump buttons do not work and there is also a glitch that make everything strobe..... We are going to call the distributer Monday to get another one sent to us, I think it might be just loose parts inside but I thought id put a bug in your ear just in case. We had the fat frog and loved it trying to find a new and lovig home for it... Thanks BOB

Share this post


Link to post
Share on other sites

If you just bought it, send it back to your distributor and they should repair/replace it for you. However if you're feeling adventurous, remove the front panel assembly from the base assembly (only 2 screws) and check all the ribbon cables are securely seated. This would be the most likely cause of the problem you describe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.