Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
ice

XL/XLS Mode Switch

Recommended Posts

Hi there,

 

My XL console isn't working any longer! Though the faders do work, and it outputs valid DMX the entire programming section is down.

 

The pagenumber display displays this:

Afbeelding(034).jpg

 

I've looked this up in the manual and that says there's a problem with the position of the mode switch. I've placed it into different positions: it seems to be fine! What other hardware problem could be causing this?

Share this post


Link to post
Share on other sites

From the picture the display is showing three bars. This means that the desk does not register which mode it is in.

This could be due to a damaged mode switch or the key decoder circuit having failed. Best guess is the mode select switch.

Share this post


Link to post
Share on other sites

Okay, we replaces the mode switch with another one. Small problem: they only had a 10-step switch, so we just bought that one. Now all of the modes seem to work again, and theres is one mode added 8O

 

Not really sure what it does, but it's there and not listed in the manual, a bit strange.

 

Just one small problem left: in program / run mode the green LEDs of some channels go on. When we power on the console they slowely come on and stay on. As far as I can judge its not really affecting output in anyway, but of course it is a bit strange. Any idea on where this is coming from?

Share this post


Link to post
Share on other sites

The added mode is a repeat of the midi functions it;s ghosting on the switch contact as reading the previous one still, on ocasion if you switch on in that mode you may get the three bars back until you turn the switch.

On most of those switchs there is normally a locking ring that can be used to set the number of positions the switch can move through.

With the desk in preset set this to position 6 and everything should be ok.

We tend to glue this to stop the ring moving.

 

The second problem has a number of possible causes.

If it is only a couple of channels then it may be a faulty analogue IC.

If it something like channel 3-12 with 1 and 2 off then it sounds like a possible fault with the ACAI IC dragging the analogue section down. The IC in question is an 63B05, try removing it and see if this cures the problem. These parts are difficult to find as they have become obsolete now.

The other thing I would also check it the battery voltage. You are looking for a voltage of at least 2.2v with out power and under 4.6 with. Also check it's condition, if it looks like it is strarting to corrode replace it.

Share this post


Link to post
Share on other sites

Nope no drinks for this one :) Though we did buy it in a non-working state, convinced we could sort it out. We did, and it worked just fine for 2 years or so, but now its started bugging again :)

Share this post


Link to post
Share on other sites

Though the consoles output seems to be fine again, we still can't get the little LEDs to come off. They just keep on being lit but don't have any noticible function anymore. We're a bit afraid on using it again cause it might fail on the job and of course that's no good. Any more ideas on what we could check to make it work again?

Share this post


Link to post
Share on other sites

The DMX output will be ok but the analogue should also have these outputs stuck on as well.

Have you tried replacing the 63B05 as mentioned on my previous posting?

As a quick test you should be able to remove the IC and be able to power the desk up with out it to see if the LEDs come on.

Share this post


Link to post
Share on other sites

Hello.

since several days, my XL wasn´t functional anymore. The uP´s interrupt line was disturbed. After removal of the MIDI interface ic HD63B50P, the table became fully functional, except for the MIDI interface. I expected that i could easily miss ic 44, because i don´t use MIDI.

Later on i noticed small voltage variations on the analog outputs , also noticeable on the green output leds. The variations are synchronous with some data on the empty icholder of ic 44. Is the uP missing ic44?

Are those ic´s still available and what will be the price of those ic´s?

 

John Smith

Share this post


Link to post
Share on other sites

Hi there.

Pardon my poor english.

I have just bought a second-, or thierd-hand, broken XLS, for what I hope is a fair price. The thing that is broken is the turnswitch for program, run, midi etc. settings. Do anyone now if I can get a sparepart to repair this?

 

Best Regards Morten

Denmark

Share this post


Link to post
Share on other sites

Hi Morten,

 

I'm really guessing now because I don't know the insides of this desk, but from posts #3 and #4 above, I suspect the rotary switch will be available off the shelf from an electronics supplier, and may be something like this:

 

http://www.rapidonline.com/Electronic-Components/Switches/Rotary-Switches/PCB-Mounting-rotary-switches/30305/kw/79-0205?

 

Hopefully Keith or Paul will pick up your post next week and confirm a suitable part... if not, have a look yourself and compare it to my suggestion.

 

Good luck.

 

Regards,

Kevin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.