Jump to content
Zero 88 Community Support Forum
liamgreenhalgh

Problem with Zero 88 LTC

Recommended Posts

Hi!

I work at a school which has the Zero 88 LTC running five lighting rigs (one duplicated so 24 channels total). After working flawlessly for years today the third rig had all its lights stuck on max regardless of is the desk was faded up or even plugged in. Turning the knobs to select test channels had no effect and the light on the front seems to indicate the dimmer is ok. The only way to turn off the lights is to throw the circuit breakers on the right hand side of the panel. The rest of the rigs are working perfectly and are responding as normal. One thing i've noticed is that the test level knob is VERY loose (in fact it's loose on all of the dimmers and only works on one) Does anyone know what might be wrong and if there is a way to fix it?

I am by no means an expert on all this however I'm the closest our school has to one! 

Thanks!

Share this post


Link to post
Share on other sites

the LTC tended to have a built in DMX unit, should be a keypad with a display on the top left of the rack.

This has an internal battery that could have failed and is cause the issue that you are seeing.

PM on the address below an I can talk you through what you need to look for. 

 

Regard

 

Keith Rogers

keithrogers@eaton.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×