Jump to content
Zero 88 Community Support Forum
Sign in to follow this  
Mal421

Fat Frog Fail

Recommended Posts

My fat Frog failed last night just before a show. it had been working fine all day and was powered down to move into the tech box. When powered up again all that happens is all the LEDs in the push buttons come on and stay on and the LCD screens are black. my Fat Frog doesn't have a VGA connector so I can't connect an external screen.

Share this post


Link to post
Share on other sites

Sounds like it could be the battery failed - if your desk doesn't have a VGA connector then it's likely that it's an early MK1 in which case it will be a soldered in NimH rechargeable.

 

If you feel confident enough to open the desk and put a voltmeter across the battery (it's obvious which is the battery) then you should get a reading of 3.6v or more - usually about 3.9v. You can swap the battery yourself but the mainboard has to come out of the desk and you need to be careful removing the battery as the through plate solder connections can easily be damaged - RS or CPC will sell you the battery. Otherwise your local Zero88 repair centre should be able to do the repair for you.

 

Whilst you have the desk open also check that the RAM stick is seated firmly in it's socket - I've never known one come loose because of the retaining clips, but there's always a first time <_<

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.